Debian LTS: DLA-3052-1: cyrus-imapd security update | LinuxSecurity...

Advisories

-------------------------------------------------------------------------
Debian LTS Advisory DLA-3052-1                [email protected]
https://www.debian.org/lts/security/                      Markus Koschany
June 20, 2022                                 https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : cyrus-imapd
Version        : 2.5.10-3+deb9u3
CVE ID         : CVE-2019-18928 CVE-2021-33582
Debian Bug     : 993433

It was discovered that the Cyrus IMAP server was prone to a denial of service
attack via input that is mishandled during hash-table interaction. Furthermore
it allowed privilege escalation because an HTTP request may be interpreted in
the authentication context of an unrelated previous request that arrived over
the same connection.

For Debian 9 stretch, these problems have been fixed in version
2.5.10-3+deb9u3.

We recommend that you upgrade your cyrus-imapd packages.

For the detailed security status of cyrus-imapd please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/cyrus-imapd

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3052-1: cyrus-imapd security update

June 19, 2022
It was discovered that the Cyrus IMAP server was prone to a denial of service attack via input that is mishandled during hash-table interaction

Summary


It was discovered that the Cyrus IMAP server was prone to a denial of service
attack via input that is mishandled during hash-table interaction. Furthermore
it allowed privilege escalation because an HTTP request may be interpreted in
the authentication context of an unrelated previous request that arrived over
the same connection.

For Debian 9 stretch, these problems have been fixed in version
2.5.10-3+deb9u3.

We recommend that you upgrade your cyrus-imapd packages.

For the detailed security status of cyrus-imapd please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/cyrus-imapd

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : cyrus-imapd
Version : 2.5.10-3+deb9u3
CVE ID : CVE-2019-18928 CVE-2021-33582
Debian Bug : 993433

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.