openSUSE: 2022:10017-1 important: chafa | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for chafa
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:10017-1
Rating:             important
References:         #1200510 
Cross-References:   CVE-2022-2061
Affected Products:
                    openSUSE Backports SLE-15-SP4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for chafa fixes the following issues:

   - CVE-2022-2061: Fix heap based buffer overflow in lzw_decode (boo#1200510)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP4:

      zypper in -t patch openSUSE-2022-10017=1



Package List:

   - openSUSE Backports SLE-15-SP4 (aarch64 i586 ppc64le s390x x86_64):

      chafa-1.8.0-bp154.3.3.1
      chafa-devel-1.8.0-bp154.3.3.1
      libchafa0-1.8.0-bp154.3.3.1

   - openSUSE Backports SLE-15-SP4 (noarch):

      chafa-doc-1.8.0-bp154.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-2061.html
   https://bugzilla.suse.com/1200510

openSUSE: 2022:10017-1 important: chafa

June 20, 2022
An update that fixes one vulnerability is now available

Description

This update for chafa fixes the following issues: - CVE-2022-2061: Fix heap based buffer overflow in lzw_decode (boo#1200510)

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Backports SLE-15-SP4: zypper in -t patch openSUSE-2022-10017=1

Package List

- openSUSE Backports SLE-15-SP4 (aarch64 i586 ppc64le s390x x86_64): chafa-1.8.0-bp154.3.3.1 chafa-devel-1.8.0-bp154.3.3.1 libchafa0-1.8.0-bp154.3.3.1 - openSUSE Backports SLE-15-SP4 (noarch): chafa-doc-1.8.0-bp154.3.3.1

References

https://www.suse.com/security/cve/CVE-2022-2061.html https://bugzilla.suse.com/1200510

Severity
Announcement ID: openSUSE-SU-2022:10017-1
Rating: important
Affected Products: openSUSE Backports SLE-15-SP4 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.