Ubuntu 5485-1: Linux kernel vulnerabilities | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5485-1
June 17, 2022

linux, linux-aws, linux-aws-hwe, linux-aws-5.13, linux-aws-5.4,
linux-azure, linux-azure-4.15, linux-azure-5.13, linux-azure-5.4,
linux-azure-fde, linux-dell300x, linux-gcp, linux-gcp-4.15,
linux-gcp-5.13, linux-gcp-5.4, linux-gke, linux-gke-5.4, linux-gkeop,
linux-gkeop-5.4, linux-hwe, linux-hwe-5.13, linux-hwe-5.4, linux-ibm,
linux-ibm-5.4, linux-intel-5.13, linux-intel-iotg, linux-kvm,
linux-lowlatency, linux-oracle, linux-oracle-5.13, linux-oracle-5.4
vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS
- Ubuntu 21.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 ESM
- Ubuntu 14.04 ESM

Summary:

Several security issues were addressed in the Linux kernel.

Software Description:
- linux: Linux kernel
- linux-aws: Linux kernel for Amazon Web Services (AWS) systems
- linux-azure: Linux kernel for Microsoft Azure Cloud systems
- linux-gcp: Linux kernel for Google Cloud Platform (GCP) systems
- linux-gke: Linux kernel for Google Container Engine (GKE) systems
- linux-ibm: Linux kernel for IBM cloud systems
- linux-intel-iotg: Linux kernel for Intel IoT platforms
- linux-kvm: Linux kernel for cloud environments
- linux-lowlatency: Linux low latency kernel
- linux-oracle: Linux kernel for Oracle Cloud systems
- linux-aws-5.13: Linux kernel for Amazon Web Services (AWS) systems
- linux-azure-5.13: Linux kernel for Microsoft Azure cloud systems
- linux-azure-fde: Linux kernel for Microsoft Azure cloud systems
- linux-gcp-5.13: Linux kernel for Google Cloud Platform (GCP) systems
- linux-gkeop: Linux kernel for Google Container Engine (GKE) systems
- linux-hwe-5.13: Linux hardware enablement (HWE) kernel
- linux-intel-5.13: Linux kernel for Intel IOTG
- linux-oracle-5.13: Linux kernel for Oracle Cloud systems
- linux-aws-5.4: Linux kernel for Amazon Web Services (AWS) systems
- linux-azure-4.15: Linux kernel for Microsoft Azure Cloud systems
- linux-azure-5.4: Linux kernel for Microsoft Azure cloud systems
- linux-dell300x: Linux kernel for Dell 300x platforms
- linux-gcp-4.15: Linux kernel for Google Cloud Platform (GCP) systems
- linux-gcp-5.4: Linux kernel for Google Cloud Platform (GCP) systems
- linux-gke-5.4: Linux kernel for Google Container Engine (GKE) systems
- linux-gkeop-5.4: Linux kernel for Google Container Engine (GKE) systems
- linux-hwe-5.4: Linux hardware enablement (HWE) kernel
- linux-ibm-5.4: Linux kernel for IBM cloud systems
- linux-oracle-5.4: Linux kernel for Oracle Cloud systems
- linux-aws-hwe: Linux kernel for Amazon Web Services (AWS-HWE) systems
- linux-hwe: Linux hardware enablement (HWE) kernel

Details:

It was discovered that some Intel processors did not completely perform
cleanup actions on multi-core shared buffers. A local attacker could
possibly use this to expose sensitive information. (CVE-2022-21123)

It was discovered that some Intel processors did not completely perform
cleanup actions on microarchitectural fill buffers. A local attacker could
possibly use this to expose sensitive information. (CVE-2022-21125)

It was discovered that some Intel processors did not properly perform
cleanup during specific special register write operations. A local attacker
could possibly use this to expose sensitive information. (CVE-2022-21166)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
  linux-image-5.15.0-1009-ibm     5.15.0-1009.11
  linux-image-5.15.0-1010-gcp     5.15.0-1010.15
  linux-image-5.15.0-1010-gke     5.15.0-1010.13
  linux-image-5.15.0-1010-intel-iotg  5.15.0-1010.14
  linux-image-5.15.0-1011-oracle  5.15.0-1011.15
  linux-image-5.15.0-1012-azure   5.15.0-1012.15
  linux-image-5.15.0-1012-kvm     5.15.0-1012.14
  linux-image-5.15.0-1013-aws     5.15.0-1013.17
  linux-image-5.15.0-39-generic   5.15.0-39.42
  linux-image-5.15.0-39-generic-64k  5.15.0-39.42
  linux-image-5.15.0-39-generic-lpae  5.15.0-39.42
  linux-image-5.15.0-39-lowlatency  5.15.0-39.42
  linux-image-5.15.0-39-lowlatency-64k  5.15.0-39.42
  linux-image-aws                 5.15.0.1013.13
  linux-image-azure               5.15.0.1012.11
  linux-image-gcp                 5.15.0.1010.9
  linux-image-generic             5.15.0.39.40
  linux-image-generic-hwe-22.04   5.15.0.39.40
  linux-image-generic-lpae        5.15.0.39.40
  linux-image-generic-lpae-hwe-22.04  5.15.0.39.40
  linux-image-gke                 5.15.0.1010.13
  linux-image-gke-5.15            5.15.0.1010.13
  linux-image-ibm                 5.15.0.1009.8
  linux-image-intel-iotg          5.15.0.1010.10
  linux-image-kvm                 5.15.0.1012.10
  linux-image-lowlatency          5.15.0.39.38
  linux-image-lowlatency-hwe-22.04  5.15.0.39.38
  linux-image-oem-20.04           5.15.0.39.40
  linux-image-oracle              5.15.0.1011.9
  linux-image-virtual             5.15.0.39.40
  linux-image-virtual-hwe-22.04   5.15.0.39.40

Ubuntu 21.10:
  linux-image-5.13.0-1030-kvm     5.13.0-1030.33
  linux-image-5.13.0-1031-aws     5.13.0-1031.35
  linux-image-5.13.0-1031-azure   5.13.0-1031.37
  linux-image-5.13.0-1033-gcp     5.13.0-1033.40
  linux-image-5.13.0-1036-oracle  5.13.0-1036.43
  linux-image-5.13.0-51-generic   5.13.0-51.58
  linux-image-5.13.0-51-generic-lpae  5.13.0-51.58
  linux-image-5.13.0-51-lowlatency  5.13.0-51.58
  linux-image-aws                 5.13.0.1031.29
  linux-image-azure               5.13.0.1031.28
  linux-image-gcp                 5.13.0.1033.28
  linux-image-generic             5.13.0.51.57
  linux-image-generic-lpae        5.13.0.51.57
  linux-image-gke                 5.13.0.1033.28
  linux-image-kvm                 5.13.0.1030.27
  linux-image-lowlatency          5.13.0.51.57
  linux-image-oem-20.04           5.13.0.51.57
  linux-image-oracle              5.13.0.1036.33
  linux-image-virtual             5.13.0.51.57

Ubuntu 20.04 LTS:
  linux-image-5.13.0-1017-intel   5.13.0-1017.19
  linux-image-5.13.0-1031-aws     5.13.0-1031.35~20.04.1
  linux-image-5.13.0-1031-azure   5.13.0-1031.37~20.04.1
  linux-image-5.13.0-1033-gcp     5.13.0-1033.40~20.04.1
  linux-image-5.13.0-1036-oracle  5.13.0-1036.43~20.04.1
  linux-image-5.13.0-51-generic   5.13.0-51.58~20.04.1
  linux-image-5.13.0-51-generic-64k  5.13.0-51.58~20.04.1
  linux-image-5.13.0-51-generic-lpae  5.13.0-51.58~20.04.1
  linux-image-5.13.0-51-lowlatency  5.13.0-51.58~20.04.1
  linux-image-5.4.0-1028-ibm      5.4.0-1028.32
  linux-image-5.4.0-1048-gkeop    5.4.0-1048.51
  linux-image-5.4.0-1070-kvm      5.4.0-1070.75
  linux-image-5.4.0-1076-gke      5.4.0-1076.82
  linux-image-5.4.0-1078-oracle   5.4.0-1078.86
  linux-image-5.4.0-1080-aws      5.4.0-1080.87
  linux-image-5.4.0-1080-gcp      5.4.0-1080.87
  linux-image-5.4.0-1085-azure    5.4.0-1085.90
  linux-image-5.4.0-1085-azure-fde  5.4.0-1085.90+cvm1.1
  linux-image-5.4.0-120-generic   5.4.0-120.136
  linux-image-5.4.0-120-generic-lpae  5.4.0-120.136
  linux-image-5.4.0-120-lowlatency  5.4.0-120.136
  linux-image-aws                 5.13.0.1031.35~20.04.25
  linux-image-aws-lts-20.04       5.4.0.1080.80
  linux-image-azure               5.13.0.1031.37~20.04.20
  linux-image-azure-fde           5.4.0.1085.90+cvm1.25
  linux-image-azure-lts-20.04     5.4.0.1085.82
  linux-image-gcp                 5.13.0.1033.40~20.04.1
  linux-image-gcp-lts-20.04       5.4.0.1080.86
  linux-image-generic             5.4.0.120.121
  linux-image-generic-hwe-20.04   5.13.0.51.58~20.04.31
  linux-image-generic-lpae        5.4.0.120.121
  linux-image-generic-lpae-hwe-20.04  5.13.0.51.58~20.04.31
  linux-image-gke                 5.4.0.1076.84
  linux-image-gke-5.4             5.4.0.1076.84
  linux-image-gkeop               5.4.0.1048.49
  linux-image-gkeop-5.4           5.4.0.1048.49
  linux-image-ibm                 5.4.0.1028.25
  linux-image-ibm-lts-20.04       5.4.0.1028.25
  linux-image-intel               5.13.0.1017.15
  linux-image-kvm                 5.4.0.1070.67
  linux-image-lowlatency          5.4.0.120.121
  linux-image-lowlatency-hwe-20.04  5.13.0.51.58~20.04.31
  linux-image-oem                 5.4.0.120.121
  linux-image-oem-osp1            5.4.0.120.121
  linux-image-oracle              5.13.0.1036.43~20.04.1
  linux-image-oracle-lts-20.04    5.4.0.1078.76
  linux-image-virtual             5.4.0.120.121
  linux-image-virtual-hwe-20.04   5.13.0.51.58~20.04.31

Ubuntu 18.04 LTS:
  linux-image-4.15.0-1048-dell300x  4.15.0-1048.53
  linux-image-4.15.0-1101-oracle  4.15.0-1101.112
  linux-image-4.15.0-1122-kvm     4.15.0-1122.127
  linux-image-4.15.0-1130-gcp     4.15.0-1130.146
  linux-image-4.15.0-1136-aws     4.15.0-1136.147
  linux-image-4.15.0-1145-azure   4.15.0-1145.160
  linux-image-4.15.0-187-generic  4.15.0-187.198
  linux-image-4.15.0-187-generic-lpae  4.15.0-187.198
  linux-image-4.15.0-187-lowlatency  4.15.0-187.198
  linux-image-5.4.0-1028-ibm      5.4.0-1028.32~18.04.1
  linux-image-5.4.0-1048-gkeop    5.4.0-1048.51~18.04.1
  linux-image-5.4.0-1076-gke      5.4.0-1076.82~18.04.1
  linux-image-5.4.0-1078-oracle   5.4.0-1078.86~18.04.1
  linux-image-5.4.0-1080-aws      5.4.0-1080.87~18.04.1
  linux-image-5.4.0-1080-gcp      5.4.0-1080.87~18.04.1
  linux-image-5.4.0-1085-azure    5.4.0-1085.90~18.04.1
  linux-image-5.4.0-120-generic   5.4.0-120.136~18.04.1
  linux-image-5.4.0-120-generic-lpae  5.4.0-120.136~18.04.1
  linux-image-5.4.0-120-lowlatency  5.4.0-120.136~18.04.1
  linux-image-aws                 5.4.0.1080.60
  linux-image-aws-lts-18.04       4.15.0.1136.136
  linux-image-azure               5.4.0.1085.62
  linux-image-azure-lts-18.04     4.15.0.1145.115
  linux-image-dell300x            4.15.0.1048.48
  linux-image-gcp                 5.4.0.1080.61
  linux-image-gcp-lts-18.04       4.15.0.1130.146
  linux-image-generic             4.15.0.187.173
  linux-image-generic-hwe-18.04   5.4.0.120.136~18.04.100
  linux-image-generic-lpae        4.15.0.187.173
  linux-image-generic-lpae-hwe-18.04  5.4.0.120.136~18.04.100
  linux-image-gke-5.4             5.4.0.1076.82~18.04.38
  linux-image-gkeop-5.4           5.4.0.1048.51~18.04.45
  linux-image-ibm                 5.4.0.1028.42
  linux-image-kvm                 4.15.0.1122.115
  linux-image-lowlatency          4.15.0.187.173
  linux-image-lowlatency-hwe-18.04  5.4.0.120.136~18.04.100
  linux-image-oem                 5.4.0.120.136~18.04.100
  linux-image-oem-osp1            5.4.0.120.136~18.04.100
  linux-image-oracle              5.4.0.1078.86~18.04.55
  linux-image-oracle-lts-18.04    4.15.0.1101.108
  linux-image-snapdragon-hwe-18.04  5.4.0.120.136~18.04.100
  linux-image-virtual             4.15.0.187.173
  linux-image-virtual-hwe-18.04   5.4.0.120.136~18.04.100

Ubuntu 16.04 ESM:
  linux-image-4.15.0-1101-oracle  4.15.0-1101.112~16.04.1
  linux-image-4.15.0-1130-gcp     4.15.0-1130.146~16.04.1
  linux-image-4.15.0-1136-aws-hwe  4.15.0-1136.147~16.04.1
  linux-image-4.15.0-1145-azure   4.15.0-1145.160~16.04.1
  linux-image-4.15.0-187-generic  4.15.0-187.198~16.04.1
  linux-image-4.15.0-187-lowlatency  4.15.0-187.198~16.04.1
  linux-image-aws-hwe             4.15.0.1136.123
  linux-image-azure               4.15.0.1145.132
  linux-image-gcp                 4.15.0.1130.127
  linux-image-generic-hwe-16.04   4.15.0.187.174
  linux-image-gke                 4.15.0.1130.127
  linux-image-lowlatency-hwe-16.04  4.15.0.187.174
  linux-image-oem                 4.15.0.187.174
  linux-image-oracle              4.15.0.1101.86
  linux-image-virtual-hwe-16.04   4.15.0.187.174

Ubuntu 14.04 ESM:
  linux-image-4.15.0-1145-azure   4.15.0-1145.160~14.04.1
  linux-image-azure               4.15.0.1145.114

Please note that fully mitigating processor vulnerabilities requires
corresponding processor microcode/firmware updates.

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

References:
  https://ubuntu.com/security/notices/USN-5485-1
  CVE-2022-21123, CVE-2022-21125, CVE-2022-21166

Package Information:
  https://launchpad.net/ubuntu/+source/linux/5.15.0-39.42
  https://launchpad.net/ubuntu/+source/linux-aws/5.15.0-1013.17
  https://launchpad.net/ubuntu/+source/linux-azure/5.15.0-1012.15
  https://launchpad.net/ubuntu/+source/linux-gcp/5.15.0-1010.15
  https://launchpad.net/ubuntu/+source/linux-gke/5.15.0-1010.13
  https://launchpad.net/ubuntu/+source/linux-ibm/5.15.0-1009.11
  https://launchpad.net/ubuntu/+source/linux-intel-iotg/5.15.0-1010.14
  https://launchpad.net/ubuntu/+source/linux-kvm/5.15.0-1012.14
  https://launchpad.net/ubuntu/+source/linux-lowlatency/5.15.0-39.42
  https://launchpad.net/ubuntu/+source/linux-oracle/5.15.0-1011.15
  https://launchpad.net/ubuntu/+source/linux/5.13.0-51.58
  https://launchpad.net/ubuntu/+source/linux-aws/5.13.0-1031.35
  https://launchpad.net/ubuntu/+source/linux-azure/5.13.0-1031.37
  https://launchpad.net/ubuntu/+source/linux-gcp/5.13.0-1033.40
  https://launchpad.net/ubuntu/+source/linux-kvm/5.13.0-1030.33
  https://launchpad.net/ubuntu/+source/linux-oracle/5.13.0-1036.43
  https://launchpad.net/ubuntu/+source/linux/5.4.0-120.136
  https://launchpad.net/ubuntu/+source/linux-aws/5.4.0-1080.87
  https://launchpad.net/ubuntu/+source/linux-aws-5.13/5.13.0-1031.35~20.04.1
  https://launchpad.net/ubuntu/+source/linux-azure/5.4.0-1085.90
  https://launchpad.net/ubuntu/+source/linux-azure-5.13/5.13.0-1031.37~20.04.1
  https://launchpad.net/ubuntu/+source/linux-azure-fde/5.4.0-1085.90+cvm1.1
  https://launchpad.net/ubuntu/+source/linux-gcp/5.4.0-1080.87
  https://launchpad.net/ubuntu/+source/linux-gcp-5.13/5.13.0-1033.40~20.04.1
  https://launchpad.net/ubuntu/+source/linux-gke/5.4.0-1076.82
  https://launchpad.net/ubuntu/+source/linux-gkeop/5.4.0-1048.51
  https://launchpad.net/ubuntu/+source/linux-hwe-5.13/5.13.0-51.58~20.04.1
  https://launchpad.net/ubuntu/+source/linux-ibm/5.4.0-1028.32
  https://launchpad.net/ubuntu/+source/linux-intel-5.13/5.13.0-1017.19
  https://launchpad.net/ubuntu/+source/linux-kvm/5.4.0-1070.75
  https://launchpad.net/ubuntu/+source/linux-oracle/5.4.0-1078.86
  https://launchpad.net/ubuntu/+source/linux-oracle-5.13/5.13.0-1036.43~20.04.1
  https://launchpad.net/ubuntu/+source/linux/4.15.0-187.198
  https://launchpad.net/ubuntu/+source/linux-aws/4.15.0-1136.147
  https://launchpad.net/ubuntu/+source/linux-aws-5.4/5.4.0-1080.87~18.04.1
  https://launchpad.net/ubuntu/+source/linux-azure-4.15/4.15.0-1145.160
  https://launchpad.net/ubuntu/+source/linux-azure-5.4/5.4.0-1085.90~18.04.1
  https://launchpad.net/ubuntu/+source/linux-dell300x/4.15.0-1048.53
  https://launchpad.net/ubuntu/+source/linux-gcp-4.15/4.15.0-1130.146
  https://launchpad.net/ubuntu/+source/linux-gcp-5.4/5.4.0-1080.87~18.04.1
  https://launchpad.net/ubuntu/+source/linux-gke-5.4/5.4.0-1076.82~18.04.1
  https://launchpad.net/ubuntu/+source/linux-gkeop-5.4/5.4.0-1048.51~18.04.1
  https://launchpad.net/ubuntu/+source/linux-hwe-5.4/5.4.0-120.136~18.04.1
  https://launchpad.net/ubuntu/+source/linux-ibm-5.4/5.4.0-1028.32~18.04.1
  https://launchpad.net/ubuntu/+source/linux-kvm/4.15.0-1122.127
  https://launchpad.net/ubuntu/+source/linux-oracle/4.15.0-1101.112
  https://launchpad.net/ubuntu/+source/linux-oracle-5.4/5.4.0-1078.86~18.04.1

Ubuntu 5485-1: Linux kernel vulnerabilities

June 16, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.04 LTS - Ubuntu 21.10 - Ubuntu 20.04 LTS - Ubuntu 18.04 LTS - Ubuntu 16.04 ESM - Ubuntu 14.04 ESM Summary: Several security issues were addressed in the Linux kernel. Software Description: - linux: Linux kernel - linux-aws: Linux kernel for Amazon Web Services (AWS) systems - linux-azure: Linux kernel for Microsoft Azure Cloud systems - linux-gcp: Linux kernel for Google Cloud Platform (GCP) systems - linux-gke: Linux kernel for Google Container Engine (GKE) systems - linux-ibm: Linux kernel for IBM cloud systems - linux-intel-iotg: Linux kernel for Intel IoT platforms - linux-kvm: Linux kernel for cloud environments - linux-lowlatency: Linux low latency kernel - linux-oracle: Linux kernel for Oracle Cloud systems - linux-aws-5.13: Linux kernel for Amazon Web Services (AWS) systems - linux-azure-5.13: Linux kernel for Microsoft Azure cloud systems - linux-azure-fde: Linux kernel for Microsoft Azure cloud systems - linux-gcp-5.13: Linux kernel for Google Cloud Platform (GCP) systems - linux-gkeop: Linux kernel for Google Container Engine (GKE) systems - linux-hwe-5.13: Linux hardware enablement (HWE) kernel - linux-intel-5.13: Linux kernel for Intel IOTG - linux-oracle-5.13: Linux kernel for Oracle Cloud systems - linux-aws-5.4: Linux kernel for Amazon Web Services (AWS) systems - linux-azure-4.15: Linux kernel for Microsoft Azure Cloud systems - linux-azure-5.4: Linux kernel for Microsoft Azure cloud systems - linux-dell300x: Linux kernel for Dell 300x platforms - linux-gcp-4.15: Linux kernel for Google Cloud Platform (GCP) systems - linux-gcp-5.4: Linux kernel for Google Cloud Platform (GCP) systems - linux-gke-5.4: Linux kernel for Google Container Engine (GKE) systems - linux-gkeop-5.4: Linux kernel for Google Container Engine (GKE) systems - linux-hwe-5.4: Linux hardware enablement (HWE) kernel - linux-ibm-5.4: Linux kernel for IBM cloud systems - linux-oracle-5.4: Linux kernel for Oracle Cloud systems - linux-aws-hwe: Linux kernel for Amazon Web Services (AWS-HWE) systems - linux-hwe: Linux hardware enablement (HWE) kernel Details: It was discovered that some Intel processors did not completely perform cleanup actions on multi-core shared buffers. A local attacker could possibly use this to expose sensitive information. (CVE-2022-21123) It was discovered that some Intel processors did not completely perform cleanup actions on microarchitectural fill buffers. A local attacker could possibly use this to expose sensitive information. (CVE-2022-21125) It was discovered that some Intel processors did not properly perform cleanup during specific special register write operations. A local attacker could possibly use this to expose sensitive information. (CVE-2022-21166)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.04 LTS: linux-image-5.15.0-1009-ibm 5.15.0-1009.11 linux-image-5.15.0-1010-gcp 5.15.0-1010.15 linux-image-5.15.0-1010-gke 5.15.0-1010.13 linux-image-5.15.0-1010-intel-iotg 5.15.0-1010.14 linux-image-5.15.0-1011-oracle 5.15.0-1011.15 linux-image-5.15.0-1012-azure 5.15.0-1012.15 linux-image-5.15.0-1012-kvm 5.15.0-1012.14 linux-image-5.15.0-1013-aws 5.15.0-1013.17 linux-image-5.15.0-39-generic 5.15.0-39.42 linux-image-5.15.0-39-generic-64k 5.15.0-39.42 linux-image-5.15.0-39-generic-lpae 5.15.0-39.42 linux-image-5.15.0-39-lowlatency 5.15.0-39.42 linux-image-5.15.0-39-lowlatency-64k 5.15.0-39.42 linux-image-aws 5.15.0.1013.13 linux-image-azure 5.15.0.1012.11 linux-image-gcp 5.15.0.1010.9 linux-image-generic 5.15.0.39.40 linux-image-generic-hwe-22.04 5.15.0.39.40 linux-image-generic-lpae 5.15.0.39.40 linux-image-generic-lpae-hwe-22.04 5.15.0.39.40 linux-image-gke 5.15.0.1010.13 linux-image-gke-5.15 5.15.0.1010.13 linux-image-ibm 5.15.0.1009.8 linux-image-intel-iotg 5.15.0.1010.10 linux-image-kvm 5.15.0.1012.10 linux-image-lowlatency 5.15.0.39.38 linux-image-lowlatency-hwe-22.04 5.15.0.39.38 linux-image-oem-20.04 5.15.0.39.40 linux-image-oracle 5.15.0.1011.9 linux-image-virtual 5.15.0.39.40 linux-image-virtual-hwe-22.04 5.15.0.39.40 Ubuntu 21.10: linux-image-5.13.0-1030-kvm 5.13.0-1030.33 linux-image-5.13.0-1031-aws 5.13.0-1031.35 linux-image-5.13.0-1031-azure 5.13.0-1031.37 linux-image-5.13.0-1033-gcp 5.13.0-1033.40 linux-image-5.13.0-1036-oracle 5.13.0-1036.43 linux-image-5.13.0-51-generic 5.13.0-51.58 linux-image-5.13.0-51-generic-lpae 5.13.0-51.58 linux-image-5.13.0-51-lowlatency 5.13.0-51.58 linux-image-aws 5.13.0.1031.29 linux-image-azure 5.13.0.1031.28 linux-image-gcp 5.13.0.1033.28 linux-image-generic 5.13.0.51.57 linux-image-generic-lpae 5.13.0.51.57 linux-image-gke 5.13.0.1033.28 linux-image-kvm 5.13.0.1030.27 linux-image-lowlatency 5.13.0.51.57 linux-image-oem-20.04 5.13.0.51.57 linux-image-oracle 5.13.0.1036.33 linux-image-virtual 5.13.0.51.57 Ubuntu 20.04 LTS: linux-image-5.13.0-1017-intel 5.13.0-1017.19 linux-image-5.13.0-1031-aws 5.13.0-1031.35~20.04.1 linux-image-5.13.0-1031-azure 5.13.0-1031.37~20.04.1 linux-image-5.13.0-1033-gcp 5.13.0-1033.40~20.04.1 linux-image-5.13.0-1036-oracle 5.13.0-1036.43~20.04.1 linux-image-5.13.0-51-generic 5.13.0-51.58~20.04.1 linux-image-5.13.0-51-generic-64k 5.13.0-51.58~20.04.1 linux-image-5.13.0-51-generic-lpae 5.13.0-51.58~20.04.1 linux-image-5.13.0-51-lowlatency 5.13.0-51.58~20.04.1 linux-image-5.4.0-1028-ibm 5.4.0-1028.32 linux-image-5.4.0-1048-gkeop 5.4.0-1048.51 linux-image-5.4.0-1070-kvm 5.4.0-1070.75 linux-image-5.4.0-1076-gke 5.4.0-1076.82 linux-image-5.4.0-1078-oracle 5.4.0-1078.86 linux-image-5.4.0-1080-aws 5.4.0-1080.87 linux-image-5.4.0-1080-gcp 5.4.0-1080.87 linux-image-5.4.0-1085-azure 5.4.0-1085.90 linux-image-5.4.0-1085-azure-fde 5.4.0-1085.90+cvm1.1 linux-image-5.4.0-120-generic 5.4.0-120.136 linux-image-5.4.0-120-generic-lpae 5.4.0-120.136 linux-image-5.4.0-120-lowlatency 5.4.0-120.136 linux-image-aws 5.13.0.1031.35~20.04.25 linux-image-aws-lts-20.04 5.4.0.1080.80 linux-image-azure 5.13.0.1031.37~20.04.20 linux-image-azure-fde 5.4.0.1085.90+cvm1.25 linux-image-azure-lts-20.04 5.4.0.1085.82 linux-image-gcp 5.13.0.1033.40~20.04.1 linux-image-gcp-lts-20.04 5.4.0.1080.86 linux-image-generic 5.4.0.120.121 linux-image-generic-hwe-20.04 5.13.0.51.58~20.04.31 linux-image-generic-lpae 5.4.0.120.121 linux-image-generic-lpae-hwe-20.04 5.13.0.51.58~20.04.31 linux-image-gke 5.4.0.1076.84 linux-image-gke-5.4 5.4.0.1076.84 linux-image-gkeop 5.4.0.1048.49 linux-image-gkeop-5.4 5.4.0.1048.49 linux-image-ibm 5.4.0.1028.25 linux-image-ibm-lts-20.04 5.4.0.1028.25 linux-image-intel 5.13.0.1017.15 linux-image-kvm 5.4.0.1070.67 linux-image-lowlatency 5.4.0.120.121 linux-image-lowlatency-hwe-20.04 5.13.0.51.58~20.04.31 linux-image-oem 5.4.0.120.121 linux-image-oem-osp1 5.4.0.120.121 linux-image-oracle 5.13.0.1036.43~20.04.1 linux-image-oracle-lts-20.04 5.4.0.1078.76 linux-image-virtual 5.4.0.120.121 linux-image-virtual-hwe-20.04 5.13.0.51.58~20.04.31 Ubuntu 18.04 LTS: linux-image-4.15.0-1048-dell300x 4.15.0-1048.53 linux-image-4.15.0-1101-oracle 4.15.0-1101.112 linux-image-4.15.0-1122-kvm 4.15.0-1122.127 linux-image-4.15.0-1130-gcp 4.15.0-1130.146 linux-image-4.15.0-1136-aws 4.15.0-1136.147 linux-image-4.15.0-1145-azure 4.15.0-1145.160 linux-image-4.15.0-187-generic 4.15.0-187.198 linux-image-4.15.0-187-generic-lpae 4.15.0-187.198 linux-image-4.15.0-187-lowlatency 4.15.0-187.198 linux-image-5.4.0-1028-ibm 5.4.0-1028.32~18.04.1 linux-image-5.4.0-1048-gkeop 5.4.0-1048.51~18.04.1 linux-image-5.4.0-1076-gke 5.4.0-1076.82~18.04.1 linux-image-5.4.0-1078-oracle 5.4.0-1078.86~18.04.1 linux-image-5.4.0-1080-aws 5.4.0-1080.87~18.04.1 linux-image-5.4.0-1080-gcp 5.4.0-1080.87~18.04.1 linux-image-5.4.0-1085-azure 5.4.0-1085.90~18.04.1 linux-image-5.4.0-120-generic 5.4.0-120.136~18.04.1 linux-image-5.4.0-120-generic-lpae 5.4.0-120.136~18.04.1 linux-image-5.4.0-120-lowlatency 5.4.0-120.136~18.04.1 linux-image-aws 5.4.0.1080.60 linux-image-aws-lts-18.04 4.15.0.1136.136 linux-image-azure 5.4.0.1085.62 linux-image-azure-lts-18.04 4.15.0.1145.115 linux-image-dell300x 4.15.0.1048.48 linux-image-gcp 5.4.0.1080.61 linux-image-gcp-lts-18.04 4.15.0.1130.146 linux-image-generic 4.15.0.187.173 linux-image-generic-hwe-18.04 5.4.0.120.136~18.04.100 linux-image-generic-lpae 4.15.0.187.173 linux-image-generic-lpae-hwe-18.04 5.4.0.120.136~18.04.100 linux-image-gke-5.4 5.4.0.1076.82~18.04.38 linux-image-gkeop-5.4 5.4.0.1048.51~18.04.45 linux-image-ibm 5.4.0.1028.42 linux-image-kvm 4.15.0.1122.115 linux-image-lowlatency 4.15.0.187.173 linux-image-lowlatency-hwe-18.04 5.4.0.120.136~18.04.100 linux-image-oem 5.4.0.120.136~18.04.100 linux-image-oem-osp1 5.4.0.120.136~18.04.100 linux-image-oracle 5.4.0.1078.86~18.04.55 linux-image-oracle-lts-18.04 4.15.0.1101.108 linux-image-snapdragon-hwe-18.04 5.4.0.120.136~18.04.100 linux-image-virtual 4.15.0.187.173 linux-image-virtual-hwe-18.04 5.4.0.120.136~18.04.100 Ubuntu 16.04 ESM: linux-image-4.15.0-1101-oracle 4.15.0-1101.112~16.04.1 linux-image-4.15.0-1130-gcp 4.15.0-1130.146~16.04.1 linux-image-4.15.0-1136-aws-hwe 4.15.0-1136.147~16.04.1 linux-image-4.15.0-1145-azure 4.15.0-1145.160~16.04.1 linux-image-4.15.0-187-generic 4.15.0-187.198~16.04.1 linux-image-4.15.0-187-lowlatency 4.15.0-187.198~16.04.1 linux-image-aws-hwe 4.15.0.1136.123 linux-image-azure 4.15.0.1145.132 linux-image-gcp 4.15.0.1130.127 linux-image-generic-hwe-16.04 4.15.0.187.174 linux-image-gke 4.15.0.1130.127 linux-image-lowlatency-hwe-16.04 4.15.0.187.174 linux-image-oem 4.15.0.187.174 linux-image-oracle 4.15.0.1101.86 linux-image-virtual-hwe-16.04 4.15.0.187.174 Ubuntu 14.04 ESM: linux-image-4.15.0-1145-azure 4.15.0-1145.160~14.04.1 linux-image-azure 4.15.0.1145.114 Please note that fully mitigating processor vulnerabilities requires corresponding processor microcode/firmware updates. After a standard system update you need to reboot your computer to make all the necessary changes. ATTENTION: Due to an unavoidable ABI change the kernel updates have been given a new version number, which requires you to recompile and reinstall all third party kernel modules you might have installed. Unless you manually uninstalled the standard kernel metapackages (e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual, linux-powerpc), a standard system upgrade will automatically perform this as well.

References

https://ubuntu.com/security/notices/USN-5485-1

CVE-2022-21123, CVE-2022-21125, CVE-2022-21166

Severity
Ubuntu Security Notice USN-5485-1

Package Information

https://launchpad.net/ubuntu/+source/linux/5.15.0-39.42 https://launchpad.net/ubuntu/+source/linux-aws/5.15.0-1013.17 https://launchpad.net/ubuntu/+source/linux-azure/5.15.0-1012.15 https://launchpad.net/ubuntu/+source/linux-gcp/5.15.0-1010.15 https://launchpad.net/ubuntu/+source/linux-gke/5.15.0-1010.13 https://launchpad.net/ubuntu/+source/linux-ibm/5.15.0-1009.11 https://launchpad.net/ubuntu/+source/linux-intel-iotg/5.15.0-1010.14 https://launchpad.net/ubuntu/+source/linux-kvm/5.15.0-1012.14 https://launchpad.net/ubuntu/+source/linux-lowlatency/5.15.0-39.42 https://launchpad.net/ubuntu/+source/linux-oracle/5.15.0-1011.15 https://launchpad.net/ubuntu/+source/linux/5.13.0-51.58 https://launchpad.net/ubuntu/+source/linux-aws/5.13.0-1031.35 https://launchpad.net/ubuntu/+source/linux-azure/5.13.0-1031.37 https://launchpad.net/ubuntu/+source/linux-gcp/5.13.0-1033.40 https://launchpad.net/ubuntu/+source/linux-kvm/5.13.0-1030.33 https://launchpad.net/ubuntu/+source/linux-oracle/5.13.0-1036.43 https://launchpad.net/ubuntu/+source/linux/5.4.0-120.136 https://launchpad.net/ubuntu/+source/linux-aws/5.4.0-1080.87 https://launchpad.net/ubuntu/+source/linux-aws-5.13/5.13.0-1031.35~20.04.1 https://launchpad.net/ubuntu/+source/linux-azure/5.4.0-1085.90 https://launchpad.net/ubuntu/+source/linux-azure-5.13/5.13.0-1031.37~20.04.1 https://launchpad.net/ubuntu/+source/linux-azure-fde/5.4.0-1085.90+cvm1.1 https://launchpad.net/ubuntu/+source/linux-gcp/5.4.0-1080.87 https://launchpad.net/ubuntu/+source/linux-gcp-5.13/5.13.0-1033.40~20.04.1 https://launchpad.net/ubuntu/+source/linux-gke/5.4.0-1076.82 https://launchpad.net/ubuntu/+source/linux-gkeop/5.4.0-1048.51 https://launchpad.net/ubuntu/+source/linux-hwe-5.13/5.13.0-51.58~20.04.1 https://launchpad.net/ubuntu/+source/linux-ibm/5.4.0-1028.32 https://launchpad.net/ubuntu/+source/linux-intel-5.13/5.13.0-1017.19 https://launchpad.net/ubuntu/+source/linux-kvm/5.4.0-1070.75 https://launchpad.net/ubuntu/+source/linux-oracle/5.4.0-1078.86 https://launchpad.net/ubuntu/+source/linux-oracle-5.13/5.13.0-1036.43~20.04.1 https://launchpad.net/ubuntu/+source/linux/4.15.0-187.198 https://launchpad.net/ubuntu/+source/linux-aws/4.15.0-1136.147 https://launchpad.net/ubuntu/+source/linux-aws-5.4/5.4.0-1080.87~18.04.1 https://launchpad.net/ubuntu/+source/linux-azure-4.15/4.15.0-1145.160 https://launchpad.net/ubuntu/+source/linux-azure-5.4/5.4.0-1085.90~18.04.1 https://launchpad.net/ubuntu/+source/linux-dell300x/4.15.0-1048.53 https://launchpad.net/ubuntu/+source/linux-gcp-4.15/4.15.0-1130.146 https://launchpad.net/ubuntu/+source/linux-gcp-5.4/5.4.0-1080.87~18.04.1 https://launchpad.net/ubuntu/+source/linux-gke-5.4/5.4.0-1076.82~18.04.1 https://launchpad.net/ubuntu/+source/linux-gkeop-5.4/5.4.0-1048.51~18.04.1 https://launchpad.net/ubuntu/+source/linux-hwe-5.4/5.4.0-120.136~18.04.1 https://launchpad.net/ubuntu/+source/linux-ibm-5.4/5.4.0-1028.32~18.04.1 https://launchpad.net/ubuntu/+source/linux-kvm/4.15.0-1122.127 https://launchpad.net/ubuntu/+source/linux-oracle/4.15.0-1101.112 https://launchpad.net/ubuntu/+source/linux-oracle-5.4/5.4.0-1078.86~18.04.1

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.