Arch Linux Security Advisory ASA-202108-1
=========================================

Severity: High
Date    : 2021-08-03
CVE-ID  : CVE-2021-22930
Package : nodejs
Type    : arbitrary code execution
Remote  : Yes
Link    : https://security.archlinux.org/AVG-2239

Summary
=======

The package nodejs before version 16.6.0-1 is vulnerable to arbitrary
code execution.

Resolution
==========

Upgrade to 16.6.0-1.

# pacman -Syu "nodejs>=16.6.0-1"

The problem has been fixed upstream in version 16.6.0.

Workaround
==========

None.

Description
===========

Node.js before version 16.6.0, 14.17.4 and 12.22.4 is vulnerable to a
use after free attack where an attacker might be able to exploit the
memory corruption, to change process behavior.

Impact
======

A remote attacker could execute arbitrary code through crafted HTTP/2
requests.

References
==========

https://nodejs.org/en/blog/vulnerability/july-2021-security-releases-2/#use-after-free-on-close-http2-on-stream-canceling-high-cve-2021-22930
https://github.com/nodejs/node/issues/38964
https://github.com/nodejs/node/pull/39423
https://github.com/nodejs/node/commit/9d950a0956bf2c3dd87bacb56807f37e16a91db4
https://github.com/nodejs/node/commit/d48b91ea2b27828ceea10dab1effa42bc542be03
https://github.com/nodejs/node/commit/b263f2585ab53f56e0e22b46cf1f8519a8af8a05
https://security.archlinux.org/CVE-2021-22930